Members | Sign In
Chippernut Forums > Support
avatar

RPM reading

posted May 17, 2016 08:59:55 by barry@host32.com
Firstly - thanks for creating this as open source - its an awesome bit of code !
Now, I've built the circuit as specified, and loaded 2.41 onto a nano - I also built the RPM generator circuit and everything works as it should - until I hook it up to the car.
engine is a Toyota 2gr-fe and I connected the 'rpm in' on the circuit to the trigger wire on the COP for cylinder #2.
The led display jumps around all the over the place reading from a few hundred rpm to 9000, regardless of selecting freq or intr with conditioning on or off.
hooked back up to the rpm generator, everything works as it should (bypassing the transistor input)
The Toyota coil is a 5v logic trigger - can you suggest where to start fault finding ?

Thanks
page   1
7 replies
avatar
BrandonMatthews said May 17, 2016 13:28:45
Have you tried using an RPM reading from the ecu? Also, normally the reading is a 12v signal, that's why there's a transistor. So maybe bypass the transistor and see what happens?
avatar
barry@host32.com said May 17, 2016 22:04:02
Thx for the reply - the ECU doesn't have a tach out - the cluster is all driven by canbus :/
have tried connecting the coil trigger bypassing the transistor - not as erratic bouncing around of the rpm, but still bouncing around all over the place ... regardless of intr or fr sens option ...
avatar
Jonduino said Sep 23, 2016 13:14:24
Hi Barry,

Sorry for the extreme delay in responding. This is probably a condition of 'wasted spark' or signal noise or both. I'm working on a solution not that uses an inductive clamp -- development is just slow going. I'll post up info when I have a definitive answer.

Sorry again for the delay
- jon
avatar
markh@doctors.org.uk said Oct 01, 2016 11:29:26
I have a (maybe) similar problem.
Bought the kit, but thought I would build it first on a breadboard with an uno.
Powered up, with nothing at all attached to pins 2 or 8, display shows a fairly steady 1480 rpm +- 10 or so.
(Set to software rpm sensing)
As soon as anything at all, even just a jumper wire, is connected to pin 8 the rpm varies wildly.
Built the RPM generator and connected this to pin 8 same result.

Set to hardware sensing I get steady 1480 rpm whatever is connected to pin 2.

Any ideas where to start looking for the problem?
Is it normal for it to show a steady 1500 rpm with no input at all?

Thanks for any help.
avatar
Jonduino said Oct 03, 2016 14:41:55
Hi --

That is an odd problem. With no input the display should be blank or at 0. I would try the following.

1) ensure you have all grounds on the same plane. The ground acts like a sync between the arduinos.
2) Run the EEPROM Reset code and wipe the arduino clean. (Should be included in the ZIP file)
3) Very all parts and connections are accurate with the 4.21 schematic (here)

avatar
markh@doctors.org.uk said Oct 03, 2016 15:15:17
So after a little thought I figured that the interference was mains electricity related as 50hz equated to 1500rpn with 2 pulses per revolution. So tried with battery power supply, but no improvement.
Rebuilt the circuit using the Nano instead of the Uno and used the UNO as the RPM generator and problem went away.
Conclusion, cheap Chinese Uno very susceptible to interference for some reason.
avatar
Jonduino said Oct 03, 2016 15:36:04
I've seen odd problems relating to those off-brand Arduino knock-offs. This is exactly why I individually test each Nano I sell w/ a testing software, wipe the EEPROM, and upload the shiftlight code to verify it works. (hence why they all come assembled w/ the headers).. It's cheaper for me to take 3 minutes and assemble/test each one than to ship out replacements.

Also - years back I experienced an odd issues with some WS2811 LEDS (older gen than the ones I ship). I found out that it was electrical noise in the mains -- whenever my window AC unit turned on the LEDs would freak out and do the craziest things. Had me chasing my tail a bit for an hour thinking it was wiring or code issue. Haha.

Glad you got it resolved!
- jon
Login below to reply: